DG59 - Troubleshooting - Fail to reconnect?

Follow

Keywords: DG59, reconnect, fail, not, connecting, can't pair, stop working, no sound

 

The USB adapter and headphones within DG59 set are LOCKED to each other, they should auto reconnect once they are turned on. Check the Leaf/DG50 (the black USB adapter) and AS9S(headphones) are connected or not.

 

Adapter & headphones are WELL connected - 

  • Headphones say 'Welcome to Avantree, Connected'
  • LED on headphones stay SOLID BLUE
  • LED on adapter flashes BLUE 3 times every 5s

 

Adapter & headphone are NOT connected - 

  • Headphones only say “Welcome to Avantree” but NO "Connected"
  • LED on headphones flashes BLUE once per 2 seconds 
  • LED on adapter flashes BLUE once every 5s

 

If you find they are NOT connected, please try Solutions below:

 

Solution 1:

Turn off the headphones and unplug DG50, wait for 10 seconds, then turn back on both devices, they should auto reconnect to each other. 

Solution 2:

  • Clear paired history of headphones: After turning on, press and hold both “+” and “-” for 10 seconds until the RED and BLUE LEDs are BOTH on for 2 seconds (looks PINK) - now all the paired history of the headphones is cleared. It then enters pairing mode automatically with the LED flashing alternately RED and BLUE.

 

  • Clear paired history of adpater: Set Leaf to PAIRING MODE – Hold MFB for 2 seconds until the LED flash BLUE and WHITE alternately.Quickly Double click the MFB to reset Leaf, the BLUE and WHITE LEDs are both on for 2 seconds. Then Leaf will automatically enter pairing mode

 

  • Keep them close and wait for 5-10 sec, they will auto-reconnect.
Have more questions? Submit a request

Comments